Corriger les problèmes de Javascript obsolète relatifs à WordPress 5.5

Word­Press 5.5 est là et vous avez fait la mise à jour et votre site est tout cassé. Je ne saurai trop rappe­ler que les mises à jour déci­males de Word­Press sont des mises à jour d’apport de fonc­tion­na­li­tés et pas de sécu­ri­té. Person­nel­le­ment, j’attends patiem­ment la version 5.5.1 avant de faire la mise à jour.

Mais ça n’explique pas pour­quoi ça ne fonc­tionne plus en passant en 5.5. Cette nouvelle version ne contient plus jQue­ry Migrate 1.4.1 qui embarque des scripts utili­sés par certaines exten­sions et certains thèmes qui n’ont pas été mis à jour depuis long­temps ou mal prépa­rés puisqu’on annonce des bugs avec Yoast ou Clas­sic Editor. L’équipe WP a donc dû déve­lop­per une exten­sion pour corri­ger ce problème : Enable jQue­ry Migrate Helper.

Si vous êtes concer­né, je vous encou­rage vive­ment à recher­cher quelle est l’origine des erreurs et contac­ter le déve­lop­peur du thème ou de l’extension fautif. En effet ce correc­tif n’a pas voca­tion à corri­ger le problème défi­ni­ti­ve­ment – le code origi­nal en est à sa version 3.0. Il faut que votre site soit à jour à tout point de vue et s’il ne fonc­tionne pas sans cette exten­sion, on peut consi­dé­rer que c’est problé­ma­tique.


site de l’extension sur word​press​.org : https://​word​press​.org/​p​l​u​g​i​n​s​/​e​n​a​b​l​e​-​j​q​u​e​r​y​-​m​i​g​r​a​t​e​-​h​e​l​p​er/ – version testée : 1.0.1

Dernière modification: 25 août 2020

Commentaires

Écrire une réponse ou un commentaire

Votre adresse email ne sera pas publiée.

Notifiez-moi les commentaires à venir via email. Vous pouvez aussi vous abonner sans commenter.