Image à la une ? Check ! Mot-clef ? Check !

N’oubliez plus les conditions de publication de vos articles

J’ai déjà par­lé ici d’un plu­gin per­met­tant aux étour­dis de ne plus oublier image à la une ou mot-clef — très utile dans mon cas — mais le plu­gin en ques­tion a été aban­don­né et il m’a fal­lut par­tir à la chasse d’une alter­na­tive. En fait, j’en ai trou­vé deux.

Post Type Requi­re­ments Che­ck­list va véri­fier

  • le titre
  • l’image à la une
  • l’extrait
  • le nombre mini­mum de caté­go­ries
  • le nombre mini­mum de mots-clef
  • jusqu’à cinq taxo­no­mies per­son­na­li­sées par type de article

Il affiche dans la side­bar d’édition de articles une liste des actions à effec­tuer en cochant celles effec­tuées et empêche la publi­ca­tion du article/​de la page tant que les actions requises n’ont pas été vali­dées. Et bien sûr, il fonc­tionne avec tous les types de conte­nu per­son­na­li­sé gérés par votre thème ou vos plu­gins.

Options

post-type-requirement-options

Affichage

post-type-requirement-visuel

Compléments

Le créa­teur du plu­gin est atten­tif à toute sug­ges­tion et ajoute des champs requis pour des plu­gins popu­laires. Sont gérés pour le moment WP SEO de Yoast et All in One SEO.

- site de l’extension : https://wordpress.org/plugins/post-type-requirements-checklist/
 — com­pa­ti­bi­li­té à ce jour : WP 3.1 > WP 4.1.1
 — ver­sion tes­tée : 2.0
 — tra­duc­tion fran­çaisse : https://www.echodesplugins.li-an.fr/mes-traductions-wp/#require

Requi­red Fields est beau­coup plus simple mais je le trouve plus agréable dans le cadre d’une uti­li­sa­tion de Word­Press sans type de conte­nu per­son­na­li­sé. Il véri­fie :

  • le titre
  • l’image à la une
  • l’extrait
  • si au moins une caté­go­rie est choi­sie
  • si au moins un mots-cle est choi­si

Vous pou­vez per­son­na­li­ser les mes­sages d’avertissement et il sou­ligne en rouge les champs man­quants.

Options

required-field-options

required-field-options-b

Affichage

required-field-message-b

required-field-message

- site de l’extension : https://wordpress.org/plugins/required-fields/
 — com­pa­ti­bi­li­té à ce jour : WP 3.x > WP 4.1.1
 — ver­sion tes­tée : 1.6

Par­ta­gez

Si vous avez trou­vé une faute d’orthographe, infor­mez-nous en sélec­tion­nant le texte en ques­tion et en appuyant sur Ctrl + Entrée s’il vous plaît,.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Notifiez-moi les commentaires à venir via email. Vous pouvez aussi vous abonner sans commenter.

Aucun support n’est fourni pour les extensions testées. Vous pouvez utiliser Markdown pour les commentaires.